You are here: Home > Participate > Join a Discussion > RIPE Forum
RIPE Forum v1.4.1

RIPE Atlas

Threaded
Collapse

[atlas] Disabling TLS 1.0 and 1.1 on RIPE Atlas anchors

User Image

Robert Kisteleki

2020-08-10 11:55:56 CET

RIPE NCC staff member

Dear RIPE Atlas users,

We received reports that the availability of TLS 1.0 and 1.1 on RIPE
Atlas anchors triggers some security alarms for some anchor hosts. Since
the anchors don't host anything sensitive, and the measurment code is
not expected to be affected by this, we will stop supporting these
protocols on the anchors (*) as of *1 September*. We'll carry on with
supporting TLS 1.2

(*) the RIPE Atlas website/UI will be unchanged for the time being
although we expect similar changes in the near future

Regards,
Robert Kisteleki
RIPE NCC



User Image

Robert Kisteleki

2020-09-01 13:40:38 CET

RIPE NCC staff member

Update: this work has been completed.

Regards,
Robert


On 2020-08-10 11:55, Robert Kisteleki wrote:
> Dear RIPE Atlas users,
> 
> We received reports that the availability of TLS 1.0 and 1.1 on RIPE
> Atlas anchors triggers some security alarms for some anchor hosts. Since
> the anchors don't host anything sensitive, and the measurment code is
> not expected to be affected by this, we will stop supporting these
> protocols on the anchors (*) as of *1 September*. We'll carry on with
> supporting TLS 1.2
> 
> (*) the RIPE Atlas website/UI will be unchanged for the time being
> although we expect similar changes in the near future
> 
> Regards,
> Robert Kisteleki
> RIPE NCC
> 
> 
> 
> 

User Image

Teun Vink

2020-09-01 14:07:18 CET

On 1 Sep 2020, at 13:40, Robert Kisteleki wrote:

> Update: this work has been completed.
>

Hi Robert,

atlas-stream.ripe.net seems to be broken on HTTP. Is that related to 
this change?

Best regards,
-- 
Teun Vink
BIT           | teun _at_ bit _dot_ nl     | +31 318 648 688
KvK: 09090351 | GPG: 0xFC8B25D6 | RIPE: TEUN-RIPE

User Image

Chris Amin

2020-09-01 15:26:18 CET

RIPE NCC staff member

On 01/09/2020 14:07, Teun Vink wrote:
> Hi Robert,
>
> atlas-stream.ripe.net seems to be broken on HTTP. Is that related to 
> this change?

Hi Teun,

This is an unrelated issue that we are looking into. I'll let you know 
when the solution is ready.

Regards,

Chris


User Image

Chris Amin

2020-09-01 15:50:53 CET

RIPE NCC staff member

This issue is now resolved, atlas-stream.ripe.net should work correctly 
again over plain HTTP.

On 01/09/2020 15:26, Chris Amin wrote:
>
> On 01/09/2020 14:07, Teun Vink wrote:
>> Hi Robert,
>>
>> atlas-stream.ripe.net seems to be broken on HTTP. Is that related to 
>> this change?
>
> Hi Teun,
>
> This is an unrelated issue that we are looking into. I'll let you know 
> when the solution is ready.
>
> Regards,
>
> Chris
>
>
>

User Image

Teun Vink

2020-09-01 16:04:55 CET


> On 1 Sep 2020, at 15:50, Chris Amin <camin _at_ ripe _dot_ net> wrote:
> 
> This issue is now resolved, atlas-stream.ripe.net should work correctly again over plain HTTP.

Confirmed: https://bit.org/network/ is showing dots again :)

Thanks for the quick fix!

cheers,
-- 
Teun Vink
BIT           | teun _at_ bit _dot_ nl     | +31 318 648 688
KvK: 09090351 | GPG: 0xFC8B25D6 | RIPE: TEUN-RIPE