You are here: Home > Participate > Join a Discussion > RIPE Forum
RIPE Forum v1.4.2

RIPE Atlas

Threaded
Collapse

[atlas] Probe disconnects every 2 hours

Daniel AJ Sokolov

2017-12-20 08:21:08 CET

Hello,

the logs for my probe (version 1) show that is has been disconnecting
very regularly every 2 hours. The uptimes are always +/- 1 hour 50
minutes, followed by a disconnect period of 5, 8, or 11 minutes.

Out of my last 25 connects, 20 are like that. 3 have double the uptime
(about 3 hours and 50 minutes), only one has almost 24 hours, and the
current one is 6 hours and counting. The disconnects there were, again,
5, 8, or 11 minutes.

However, I to not notice similar disconnects as a user of the same
network. I sometimes listen to online streams for more then 2 hours
without interruption. I work on my computer for more than 2 hours and
don't notice these interruptions of my internet access.

It's all IPv4; no IPv6 here. The controller is ctr-fnc01.

What could be the cause of these log entries?

BR
Daniel AJ

User Image

Philip Homburg

2017-12-20 13:48:22 CET

RIPE NCC staff member

Hi,

Maybe you can mention your probe ID. That makes it easier to figure out
what is going on.

Philip

Daniel AJ Sokolov

2017-12-20 20:41:34 CET

On 2017-12-20 at 04:48 AM, Philip Homburg wrote:
> Hi,
> 
> Maybe you can mention your probe ID. That makes it easier to figure out
> what is going on.
> 
> Philip
> 

It is 1118.
Daniel AJ

User Image

Philip Homburg

2017-12-21 11:55:17 CET

RIPE NCC staff member

On 2017/12/20 20:41 , Daniel AJ Sokolov wrote:
> It is 1118.

Your probe seems to reboot every two hours. V1 probes suffer from memory
fragmentation, so when the ssh connection breaks, they often reboot.
However I cannot find anything related to that in the logs.

A reboot can be caused by a power failure. Do you have anything that
might be causing that?

Alternatively, there may be a software bug that triggers the reboot.

Other V1 probes that connect to the same controller seem fine. So either
you probe gets a specific measurement that triggers a bug, or there is a
power issue.

How is the probe powered?

Philip