You are here: Home > Participate > Join a Discussion > RIPE Forum
RIPE Forum v1.4.1

RIPE Atlas

Threaded
Collapse

Re: [atlas] Possible paging bug on RIPE Atlas Probes page with iltered results

User Image

T T

2022-01-14 03:07:47 CET

Hello,

It's not you, it's not your browser.

It is indeed a bug that exists since the new design of the RIPE Atlas
website (Quite a few months ago), I reported it in the survey of usability
and improvement of the site, but apparently it still exists to this day.

You can use these urls as a workaround:

Pages: public=1, public=2, public=3, etc.

Status=0: Never Connected
Status=1: Connected
Status=2: Disconnected

country=US: Country code

https://atlas.ripe.net/frames/probes/?public=1&search=&status=0&af=&country=NL#tab-public

https://atlas.ripe.net/frames/probes/?public=1&search=&status=1&af=&country=NL#tab-public

https://atlas.ripe.net/frames/probes/?public=1&search=&status=2&af=&country=NL#tab-public

At least it's a little more usable this way. Apparently the menus of the
old design are still standing in the new design, so it does not recognize
the filters.

Regards,
Spiroku

On Sun, Jan 9, 2022 at 8:00 AM <ripe-atlas-request _at_ ripe _dot_ net> wrote:

> Send ripe-atlas mailing list submissions to
>         ripe-atlas _at_ ripe _dot_ net
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://lists.ripe.net/mailman/listinfo/ripe-atlas
> or, via email, send a message with subject or body 'help' to
>         ripe-atlas-request _at_ ripe _dot_ net
>
> You can reach the person managing the list at
>         ripe-atlas-owner _at_ ripe _dot_ net
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of ripe-atlas digest..."
>
>
> Today's Topics:
>
>    1.  Possible paging bug on RIPE Atlas Probes page with iltered
>       results (Kristijonas Lukas Bukauskas)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Sat, 08 Jan 2022 21:31:16 +0200
> From: Kristijonas Lukas Bukauskas <kb _at_ tsig _dot_ nl>
> To: ripe-atlas _at_ ripe _dot_ net
> Subject: [atlas] Possible paging bug on RIPE Atlas Probes page with
>         iltered results
> Message-ID: <3b2f50c2f2d09b3bed26285510e5c80d _at_ tsig _dot_ nl>
> Content-Type: text/plain; charset=US-ASCII; format=flowed
>
> Hello,
>
> I hope bugs can be reported to this mailing since it is followed and
> answered by RIPE Atlas developers.
>
> On Probes page (https://atlas.ripe.net/probes/) when filtering results
> (by any criterion), navigating to the next page (with >) results in
> resetting the filter.
>
> Expected behavior: filtered results not only on the first, but any other
> following page when navigating through pages.
>
> Tested with Firefox 78.15.0esr (64-bit) and Google Chrome 95.0.4638.69
> (Official Build) (64-bit).
>
> Is it just me or a bug?
>
> --
> Regards
> Kristijonas Lukas Bukauskas
>
>
>
> End of ripe-atlas Digest, Vol 125, Issue 2
> ******************************************
>

Michael Virgilio

2022-01-14 12:04:44 CET

I'll note that this issue also applies to the UDM searches... if you adjust the fields, then click the Next Page button, the results returned become unfiltered.

On Thu, Jan 13, 2022, at 9:07 PM, T wrote:
> Hello, 
> 
> It's not you, it's not your browser. 
> 
> It is indeed a bug that exists since the new design of the RIPE Atlas website (Quite a few months ago), I reported it in the survey of usability and improvement of the site, but apparently it still exists to this day.
> 
> You can use these urls as a workaround:
> 
> Pages: public=1, public=2, public=3, etc.
> 
> Status=0: Never Connected
> Status=1: Connected
> Status=2: Disconnected
> 
> country=US: Country code
> 
> https://atlas.ripe.net/frames/probes/?public=1&search=&status=0&af=&country=NL#tab-public
> 
> https://atlas.ripe.net/frames/probes/?public=1&search=&status=1&af=&country=NL#tab-public
> 
> https://atlas.ripe.net/frames/probes/?public=1&search=&status=2&af=&country=NL#tab-public
> 
> At least it's a little more usable this way. Apparently the menus of the old design are still standing in the new design, so it does not recognize the filters.
> 
> Regards,
> Spiroku  
> 
> On Sun, Jan 9, 2022 at 8:00 AM <ripe-atlas-request _at_ ripe _dot_ net> wrote:
>> Send ripe-atlas mailing list submissions to
>>         ripe-atlas _at_ ripe _dot_ net
>> 
>> To subscribe or unsubscribe via the World Wide Web, visit
>>         https://lists.ripe.net/mailman/listinfo/ripe-atlas
>> or, via email, send a message with subject or body 'help' to
>>         ripe-atlas-request _at_ ripe _dot_ net
>> 
>> You can reach the person managing the list at
>>         ripe-atlas-owner _at_ ripe _dot_ net
>> 
>> When replying, please edit your Subject line so it is more specific
>> than "Re: Contents of ripe-atlas digest..."
>> 
>> 
>> Today's Topics:
>> 
>>    1.  Possible paging bug on RIPE Atlas Probes page with iltered
>>       results (Kristijonas Lukas Bukauskas)
>> 
>> 
>> ----------------------------------------------------------------------
>> 
>> Message: 1
>> Date: Sat, 08 Jan 2022 21:31:16 +0200
>> From: Kristijonas Lukas Bukauskas <kb _at_ tsig _dot_ nl>
>> To: ripe-atlas _at_ ripe _dot_ net
>> Subject: [atlas] Possible paging bug on RIPE Atlas Probes page with
>>         iltered results
>> Message-ID: <3b2f50c2f2d09b3bed26285510e5c80d _at_ tsig _dot_ nl>
>> Content-Type: text/plain; charset=US-ASCII; format=flowed
>> 
>> Hello,
>> 
>> I hope bugs can be reported to this mailing since it is followed and 
>> answered by RIPE Atlas developers.
>> 
>> On Probes page (https://atlas.ripe.net/probes/) when filtering results 
>> (by any criterion), navigating to the next page (with >) results in 
>> resetting the filter.
>> 
>> Expected behavior: filtered results not only on the first, but any other 
>> following page when navigating through pages.
>> 
>> Tested with Firefox 78.15.0esr (64-bit) and Google Chrome 95.0.4638.69 
>> (Official Build) (64-bit).
>> 
>> Is it just me or a bug?
>> 
>> -- 
>> Regards
>> Kristijonas Lukas Bukauskas
>> 
>> 
>> 
>> End of ripe-atlas Digest, Vol 125, Issue 2
>> ******************************************
User Image

Robert Kisteleki

2022-01-14 12:23:56 CET

RIPE NCC staff member

Thank you all for these observations! These are indeed problems that 
appeared with our transition to the current UI. We're sorry for the 
inconvenience and will fix these issues.

Regards,
Robert


On 2022-01-14 12:04, Michael Virgilio via ripe-atlas wrote:
> I'll note that this issue also applies to the UDM searches... if you 
> adjust the fields, then click the Next Page button, the results returned 
> become unfiltered.
> 
> On Thu, Jan 13, 2022, at 9:07 PM, T wrote:
>> Hello,
>>
>> It's not you, it's not your browser.
>>
>> It is indeed a bug that exists since the new design of the RIPE Atlas 
>> website (Quite a few months ago), I reported it in the survey of 
>> usability and improvement of the site, but apparently it still exists 
>> to this day.
>>
>> You can use these urls as a workaround:
>>
>> Pages: public=1, public=2, public=3, etc.
>>
>> Status=0: Never Connected
>> Status=1: Connected
>> Status=2: Disconnected
>>
>> country=US: Country code
>>
>> https://atlas.ripe.net/frames/probes/?public=1&search=&status=0&af=&country=NL#tab-public 
>> 
>>
>> https://atlas.ripe.net/frames/probes/?public=1&search=&status=1&af=&country=NL#tab-public 
>> 
>>
>> https://atlas.ripe.net/frames/probes/?public=1&search=&status=2&af=&country=NL#tab-public 
>> 
>>
>> At least it's a little more usable this way. Apparently the menus of 
>> the old design are still standing in the new design, so it does not 
>> recognize the filters.
>>
>> Regards,
>> Spiroku
>>
>> On Sun, Jan 9, 2022 at 8:00 AM <ripe-atlas-request _at_ ripe _dot_ net 
>> ripe-atlas-request _at_ ripe _dot_ net>> wrote:
>>
>>     Send ripe-atlas mailing list submissions to
>>     ripe-atlas _at_ ripe _dot_ net ripe-atlas _at_ ripe _dot_ net>
>>
>>     To subscribe or unsubscribe via the World Wide Web, visit
>>     https://lists.ripe.net/mailman/listinfo/ripe-atlas
>>     
>>     or, via email, send a message with subject or body 'help' to
>>     ripe-atlas-request _at_ ripe _dot_ net ripe-atlas-request _at_ ripe _dot_ net>
>>
>>     You can reach the person managing the list at
>>     ripe-atlas-owner _at_ ripe _dot_ net ripe-atlas-owner _at_ ripe _dot_ net>
>>
>>     When replying, please edit your Subject line so it is more specific
>>     than "Re: Contents of ripe-atlas digest..."
>>
>>
>>     Today's Topics:
>>
>>        1.  Possible paging bug on RIPE Atlas Probes page with iltered
>>           results (Kristijonas Lukas Bukauskas)
>>
>>
>>     ----------------------------------------------------------------------
>>
>>     Message: 1
>>     Date: Sat, 08 Jan 2022 21:31:16 +0200
>>     From: Kristijonas Lukas Bukauskas <kb _at_ tsig _dot_ nl kb _at_ tsig _dot_ nl>>
>>     To: ripe-atlas _at_ ripe _dot_ net ripe-atlas _at_ ripe _dot_ net>
>>     Subject: [atlas] Possible paging bug on RIPE Atlas Probes page with
>>             iltered results
>>     Message-ID: <3b2f50c2f2d09b3bed26285510e5c80d _at_ tsig _dot_ nl
>>     3b2f50c2f2d09b3bed26285510e5c80d _at_ tsig _dot_ nl>>
>>     Content-Type: text/plain; charset=US-ASCII; format=flowed
>>
>>     Hello,
>>
>>     I hope bugs can be reported to this mailing since it is followed and
>>     answered by RIPE Atlas developers.
>>
>>     On Probes page (https://atlas.ripe.net/probes/
>>     ) when filtering results
>>     (by any criterion), navigating to the next page (with >) results in
>>     resetting the filter.
>>
>>     Expected behavior: filtered results not only on the first, but any
>>     other
>>     following page when navigating through pages.
>>
>>     Tested with Firefox 78.15.0esr (64-bit) and Google Chrome
>>     95.0.4638.69
>>     (Official Build) (64-bit).
>>
>>     Is it just me or a bug?
>>
>>     -- 
>>     Regards
>>     Kristijonas Lukas Bukauskas
>>
>>
>>
>>     End of ripe-atlas Digest, Vol 125, Issue 2
>>     ******************************************
>